Hp LaserJet P1505 – ¡¡¡La impresora endemoniada!!!!!

19 05 2009

Si señores la Laserjet P1505 es una impresora endemoniada y para colmo con un soporte espantoso en GNU/Linux. El principal problema que tiene esta impresora es que requiere, al iniciarla, la carga de firmware propietario para que empiece a funcionar.
Normalmente las impresoras funcionan con solo instalar los controladores en la PC  (sea Windows, Linux, MacOS), pero en este modelo no es así y por lo que tengo entendido hay otros modelos de HP que funcionan de similar manera.
En la página del fabricante informan que el producto tiene soporte en GNU/Linux utilizando un contolador libre llamado HPLIP. En un primer momento pudimos hacer funcionar esta impresora con este controlador, pero luego de un tiempo dejo de funcionar y ni actualizando el paquete (el cual requiere ser compilado e instalado) volvió a funcionar.
Buscando por Internet, mi compañero Cristian, encontró un filtro foomatic que soporta el protocolo XQX utilizado por estas impresoras.

El caso es que este controlador me permitió hacer funcionar la impresora, además de poder compartirala dentro de la red utilizando cups y samba.

El procedimiento para que funcione en OpenSuse 10.3 y 11.x es el siguiente:

Como primera medida deberemos eliminar, en el caso de estar instalado alguna versión anterior de este controlador, siempre y cuando se ayan instalado desde repositorios alternativos o de manera manual:

#> sudo rpm -e foo2zjs
#> sudo rpm -e foo2xqx

Si la impresora está conectada la desconecto y además la apago.

Como prerequisitos a fin de poder realizar la compilación del controlador deberemos instalar los siguientes paquetes:

  • make
  • gcc

Podemos hacerlo desde la consola (como superusuario) utilizando el siguiente comando:

#> zypper install make gcc

En la 10.3 además deberemos ejecutar lo siguiente:

#> zypper service-add \
        http://download.opensuse.org/repositories/Printing/openSUSE_10.3/ \
        Printing
#> zypper up -r Printing -t package

Ahora descargamos el paquete tar.gz con los fuentes y lo descomprimios:

#> wget -O foo2zjs.tar.gz http://foo2zjs.rkkda.com/foo2zjs.tar.gz
#> tar zxf foo2zjs.tar.gz
#> cd foo2zjs

Compilamos el contorlador:

#> make

Descargamos el firmware de la impresora:

#> ./getweb P1505

Ahora como superusuario o con el comando sudo instalamos los filtros foomatic:

#> sudo make install

En el caso de que la impresora se conecte por USB deberemos además instalar el hotplug:

#> sudo make install-hotplug

Ahora reniciamos cups:

#> sudo make cups

Listo, lo unico que queda es configurar la impresora en cups.
Para esto conecto la impresora y la enciendo.
Ahora ejecuto:

#> sudo yast2 printer

Y configuro la impresora siguiendo los pasos habituales.

Espero que les sirva.


Acciones

Information

2 responses

23 05 2009
criadoindomable

Ja, tuve que pelear en una oportunidad con ese XQX. Me volví loco para hacerlo andar y no pude (eso hace más de un año) voy a probar esto que comentas.

6 08 2009
Jesus Pina

Eso de eliminar los controladores que vienen en los repositorios tambien funciona para las distros basadas en Debian, en la que lo he instalado sin problemas en en Debian Sid tanto con KDE como con GNOME, sin embargo aun no puedo hacerla funcionar en debian Lenny con Fluxbox es para una compu viejita que no soporta ni GNOME ni KDE.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s




A %d blogueros les gusta esto: